Smart Photo Editor Plug-ins

Due to a recent update to Adobe Creative Cloud the location for plug-ins has changed. If you get this problem, simply re-run the full installer for Smart Photo Editor Studio or Studio Max and your plug-in will be restored. If you don't have the installer, please get it from our license manager page
To set up Smart Photo Editor as an external editor for Lightroom, please follow these steps:
  • Open Lightroom and in the menu go to Edit->Preferences...
  • In the "Additional External Editor" section, press the "Choose" button on the right for choosing the application. A new dialog will pop up asking for the location of the program to run.
    Smart Photo Editor Studio is usually located at C:\Program Files(x86)\SmartPhotoEditorStudio\SmartPhotoEditor.exe.
    Try pasting in these paths if you are not sure. Then press "Choose" to dismiss the dialog.
  • For the "File Format" please select TIFF. The other settings can be chosen as you wish (for example: "Color Space": sRGB, "Bit Depth":8 bits/component, "Resolution":240, "Compression": LZW ).
  • Press the "OK" button to dismiss the Preferences dialog.
  • Open Smart Photo Editor Studio, choose File and Settings, and make sure "Auto-Plugin Mode" is selected.
  • Smart Photo Editor Studio is now set up as an external editor for your images. You can now select a picture in your library, right click and choose "Edit In" and then "Edit in SmartPhotoEditorStudio".
Please note that only the Studio edition of Smart Photo Editor can work as a Photoshop plugin.
This is done by running the program PhotoshopPluginInstaller. You can find this in the installation folder for Smart Photo Editor, but the easiest way to run it is by running the installer for Smart Photo Editor to re-install everything again, which includes the installer for the plug-in.
The plug-in installer will detect what version of Photoshop you have installed, and automatically find the Plug-Ins folder for you. However, if the correct place is not detected you can manually browse to the Plug-Ins folder of the Photoshop you want to use. Please make sure to check that the installation folder that Smart Photo Editor Studio gives you is correct for the version of Photoshop that you want to use.
On a Mac, the Photoshop CS6 Plug-In directory is normally:
\Applications\Adobe Photoshop CS6\Plug-Ins
For Windows, the Photoshop CS6 Plug-in folder is normally
64-bit plug-in: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 bit)\Plug-Ins
32-bit plug-in: C:\Program Files(x86)\Adobe\Adobe Photoshop CS6\Plug-Ins
When launching Photoshop, make sure that you launch the Photoshop where you have installed the plug-in. If you launch a different Photoshop, that will not have the plug-in installed, and Smart Photo Editor won't show up in the menu.
On a Mac, this is usually where to find Photoshop CS6:
\Applications\Adobe Photoshop CS6
For Windows, this is usually where to find Photoshop CS6:
64-bit plug-in: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 bit)
32-bit plug-in: C:\Program Files(x86)\Adobe\Adobe Photoshop CS6
Photoshop needs to be restarted before it will use a new plug-in. When the plug-in is installed, you can see it in Photoshop by selecting the Filter menu option. Look down the list of filters and at the end will an entry "Anthropics". Choose this and you will see it expand to show the Smart Photo Editor Studio plug-in.
This is done by running the program PhotoshopPluginInstaller. You can find this in the installation folder for Smart Photo Editor, but the easiest way to run it is by running the installer for Smart Photo Editor to re-install everything again, which includes the installer for the plug-in.
The plug-in installer will detect what version of Photoshop you have installed, and automatically find the Plug-Ins folder for you. However, if the correct place is not detected you can manually browse to the Plug-Ins folder of the Photoshop you want to use. Please make sure to check that the installation folder that Smart Photo Editor Studio gives you is correct for the version of Photoshop that you want to use.
On a Mac, the Elements Plug-In directory is normally:
/Applications/Adobe Photoshop Elements/Plug-Ins
For Windows, the Photoshop Elements Plug-in folder is normally
64-bit plug-in: C:\Program Files\Adobe\Adobe Photoshop Elements (64 bit)\Plug-Ins
32-bit plug-in: C:\Program Files(x86)\Adobe\Adobe Photoshop Elements\Plug-Ins
When launching Elements, make sure that you launch the Elements where you have installed the plug-in. If you launch a different Elements, that will not have the plug-in installed, and SmartPhotoEditor won't show up in the menu.
On a Mac, this is usually where to find Photoshop Elements:
/Applications/Adobe Photoshop Elements
For Windows, this is usually where to find Photoshop Elements:
64-bit plug-in: C:\Program Files\Adobe\Adobe Photoshop Elements (64 bit)
32-bit plug-in: C:\Program Files(x86)\Adobe\Adobe Photoshop Elements
Elements needs to be restarted before it will use a new plug-in. When the plug-in is installed, you can see it in Elements by selecting the Filter menu option. Look down the list of filters and at the end will an entry "Anthropics". Choose this and you will see it expand to show the Smart Photo Editor Studio plug-in.